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Preface

Intended Audience

This manual is for programmers at all levels of experience. It covers both user
interfaces of the debugger:

¢ The VMS DECwindows interface, for workstations
¢ The command interface, for terminals and workstations

The debugger can be used with most VAX languages. This manual emphasizes
usage that is common to all or most languages. For additional information
that is specific to a particular language, see Appendix E and the documentation
furnished with that language.

Note that you can use the VMS Debugger only to debug code in user mode. You
cannot debug any code in supervisor, executive, or kernel modes. If you need
to debug code in other than user mode, refer to the VMS Delta /XDelta Utility
Manual.

Document Structure

This manual is organized in two parts:

¢ Part I introduces the debugger’s DECwindows interface. Additional
information about the DECwindows interface is available through online
help, as explained in Chapter 1.

¢ Part IT completely describes the debugger’s command interface:
— Chapter 2 introduces the command interface.

— The remaining chapters provide task-oriented and conceptual information.
To simplify the discussions, many details about the debugger commands
are not included in these chapters.

— The command dictionary provides complete reference information about
all debugger commands.

— The appendixes provide reference details about specific subjects.

Associated Documents

General information about the VMS DECwindows interface is available in the
VMS DECwindows User’s Guide.

Information about compiling and debugging that is specific to a particular
language is available in the documentation furnished with that language and in
Appendix E of this manual.

Information about VAX assembly-language instructions and the VAX MACRO
assembler is available in the VAX MACRO and Instruction Set Reference Manual.

Xix



Information about the linking of programs and about shareable images is
available in the VMS Linker Utility Manual.

Conventions

The following conventions are used in this manual:

mouse

MB1, MB2, MB3
Ctrl/x

PF1x

)

[]

{}

red ink

numbers

XX

The term mouse refers to any pointing device, such as a
mouse, puck, or stylus.

MB1 indicates the left mouse button, MB2 indicates the
middle mouse button, and MB3 indicates the right mouse
button. (The buttons can be redefined by the user.)

A sequence such as Ctrl/x indicates that you must hold down
the Ctrl key while you press another key or a pointing device
button.

A sequence such as PF1 x indicates that you must first press
and release the PF1 key and then press and release another
key or a pointing device button.

In examples, a key name is enclosed in a box to indicate that
you press a key on the keyboard. (In text, a key name is not
enclosed in a box.)

In examples, a horizontal ellipsis indicates one of the
following possibilities:

¢ Additional optional arguments in a statement have been
omitted.

¢ The preceding item or items can be repeated one or more
times.

¢ Additional parameters, values, or other information can
be entered.

A vertical ellipsis indicates an omission in a code example
because the omitted items are not important to the topic
being discussed.

In format descriptions, parentheses indicate that, if you
choose more than one option, you must enclose the choices in
parentheses.

In format descriptions, brackets indicate that whatever is
enclosed within the brackets is optional; you can select none,
one, or all of the choices. (Brackets are not, however, optional
in the syntax of a directory name in a file specification or

in the syntax of a substring specification in an assignment
statement.)

In format descriptions, braces surround a required choice of
options; you must choose one of the options listed.

Red ink indicates information that you must enter from the
keyboard or a screen object that you must choose or click on.

For online versions of the book, user input is shown in bold.

Unless otherwise noted, all numbers in the text are assumed

to be decimal. Nondecimal radixes—binary, octal, or
hexadecimal—are explicitly indicated.
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Using the Debugger: DECwindows Interface

This part introduces the VMS debugger’s DECwindows interface. Additional
information about the DECwindows interface is available through online help.

For information about the debugger’s command interface, see Part II.
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Introduction to the Debugger: DECwindows
Interface

This chapter introduces the VMS debugger’s DECwindows interface and provides
enough information to get you started. For information about the debugger’s
command interface, see Part II of this manual, which starts with Chapter 2.

The following information is provided in this chapter:
* An overview of the debugger’s main features

¢ Instructions to prepare your program for debugging and start a debugging
session

* An overview of the debugger windows and menus
¢ A sample session to get you started with the debugger
¢ Introductions to most of the functions you can perform with the debugger.

Many topics are covered very briefly. The documentation for the debugger’s
DECwindows interface consists mainly of online help, and this chapter includes
numerous references to specific topics in the debugger’s Help menu, in the main
window. The debugger’s online help system is explained in Section 1.5.1.

To use this chapter most effectively, read it while running the debugger on your
workstation.

It is assumed that you are familiar with the general DECwindows environment
as described in the VMS DECwindows User’s Guide—that is, you should know
how to use the pointer and keyboard to manipulate ‘windows, menus, dialog
boxes, online help, and so on.

If you are already familiar with the debugger’s command interface, including how
to invoke the debugger from DCL level (as described in Part II of this manual),
you can start with Section 1.2.3.

1.1 Overview of the Debugger

The debugger is a tool that helps you locate run-time programming or logic
errors, also known as bugs. You use the debugger with a program that has
been compiled and linked successfully but does not run correctly. For example,
the program might give incorrect output, go into an infinite loop, or terminate
prematurely.

You locate errors with the debugger by observing and manipulating your program
interactively as it executes. The debugger enables you to do the following tasks:

¢ Control the program’s execution—start the program, stop at points of interest,
resume execution, and so on

¢ Trace the execution path of the program
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* Monitor changes in variables and other program entities
e Monitor exception conditions and language-specific events
¢ Examine and modify the values of variables, or force events to occur

* In some cases, test the effect of modifications without having to edit the
source code, recompile, and relink

These are the basic debugging techniques. After you are satisfied that you have
found the error in the program, you can edit the source code and compile, link,
and execute the corrected version.

As you use the debugger and its documentation (particularly the online help), you
will discover variations on the basic techniques. You can also tailor the debugger
for your own needs.

The debugger is a symbolic debugger. You can specify variable names, routine
names, and so on, precisely as they appear in your source code. You do not
need to specify memory addresses or VAX registers when referring to program
locations, although you can, if you want.

You can use the debugger with the following VAX languages:

Ada
BASIC
BLISS

C

COBOL
DIBOL
FORTRAN
MACRO-32
Pascal
PLA

RPG II
SCAN

The debugger recognizes the syntax, data typing, operators, expressions, scoping
rules, and other constructs of a given language. If your program is written

in more than one language, you can change the debugging context from one
language to another during a debugging session.

1.2 Starting a Debugging Session

The usual way to invoke the debugger from a DECterm window is as follows:
1. Compile and link the program with the /DEBUG command qualifier.

2. Make sure that the debugging configuration (default or multiprocess) is
appropriate for the kind of program you are going to debug.

3. Invoke the debugger by entering the DCL command RUN.

These steps are explained in the following sections. Additional options for
invoking the debugger are discussed in Section 1.6.
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1.2.1 Compiling and Linking a Program to Prepare for Debugging

Before you can use the debugger, you must compile and link the modules
(compilation units) of your program as explained in this section. The following
example shows how to compile and link a Pascal program, consisting of a single
compilation unit named EIGHTQUEENS, before using the debugger.

Note

The /DEBUG and /NOOPTIMIZE qualifiers are compiler command
defaults for some languages. These qualifiers are used in the example for
emphasis.

$ PASCAL/DEBUG/NOOPTIMIZE EIGHTQUEENS
$ LINK/DEBUG EIGHTQUEENS

The /DEBUG qualifier on the compiler command (PASCAL in this case) directs
the compiler to write the symbol information associated with EIGHTQUEENS .
into the object module, EIGHTQUEENS.OBJ, in addition to the code and data for
the program. This symbol information enables you to use the names of variables
and other symbols declared in EIGHTQUEENS in debugger dialog boxes and
commands. If your program has several compilation units, you must compile each
unit whose symbols you want to reference with the /DEBUG qualifier.

Some compilers optimize the object code to reduce the size of the program or

to make it run faster. In such cases you should compile your program with the
/NOOPTIMIZE command qualifier (or equivalent) when preparing for debugging.
Otherwise, the contents of some program locations might be inconsistent with
what you would expect from viewing the source code. (After the program has
been debugged, you will probably want to recompile it without the /NOOPTIMIZE
qualifier to take advantage of optimization.)

The /DEBUG qualifier on the LINK command directs the linker to include all
symbol information that is contained in EIGHTQUEENS.OBJ in the executable
image. The qualifier also causes the VMS image activator to start the debugger
at run time. If your program has several object modules, you need to specify
those modules in the LINK command, for most languages.

1.2.2 Establishing the Debugging Configuration

Before invoking the debugger as explained in Section 1.2.3, check that the
debugging configuration is appropriate for the kind of program you are going to
debug.

You can invoke the debugger in either the default configuration or the
multiprocess configuration to debug programs that run in either one or several
processes, respectively. The configuration depends on the current definition of
the logical name DBG$PROCESS. Thus, before invoking the debugger, enter the
DCL command SHOW LOGICAL DBG$PROCESS to determine the definition of
DBG$PROCESS.

Most of this chapter covers programs that run in only one process. For such
programs, DBG$PROCESS either should be undefined, as in the following
example, or should have the value DEFAULT:

$ SHOW LOGICAL DBGSPROCESS
%SHOW-S-NOTRAN, no translation for logical name DBGSPROCESS
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If DBG$PROCESS has the value MULTIPROCESS, and you want to debug a
program that runs in only one process, enter the following command:

$ DEFINE DBG$PROCESS DEFAULT

For more information about multiprocess debugging, see Section 1.5.16.

1.2.3 Invoking the Debugger
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After you compile and link your program and establish the appropriate debugging
configuration, you can then invoke the debugger. To do so, enter the DCL
command RUN, specifying the executable image of your program as the
parameter. For example, enter the following command to debug the program
EIGHTQUEENS:

$ RUN EIGHTQUEENS

By default, the debugger comes up in the following three windows, arranged as
shown in Figure 1-1:

* The main window.

¢ The predefined source window SRC, which shows the source code of the
module you are debugging. The numbers shown at the left of the source code
are compiler-generated line numbers, as they might appear in a compiler-
generated listing file.

¢ The predefined output window OUT, which displays the debugger’s output.
For example, it shows the value of a variable that you are examining.



Introduction to the Debugger: DECwindows Interface
1.2 Starting a Debugging Session

Figure 1-1 Debugger Windows at Startup
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Windows SRC and OUT are two examples of the kinds of debugger windows you
can use to capture and display different types of data.

The message that is displayed in window OUT at debugger startup indicates
that this debugging session is initialized for a Pascal program and that the name
of the main program unit (the module containing the image transfer address)

is EIGHTQUEENS. The initialization sets up language-dependent debugger
parameters.

By default, the boxed line in window SRC indicates where execution is currently
suspended. When you start a debugging session, the debugger usually suspends
execution at the beginning of the main program (line 1, in this example). For Ada
programs and certain other kinds of programs, execution is initially suspended
at the beginning of initialization code, before the main program, so that you can
choose to execute that code under debugger control. To execute to the beginning
of the main program in such cases, click on the Go button in the main window.
See your language documentation for more information.

You can now use the debugger to start execution, set breakpoints, examine
variables, and so on, as explained in Section 1.4 and Section 1.5. Section 1.3 gives
an overview of the debugger’s windows and menus.
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1.3 Debugger Windows and Menus

The debugger windows consist of a main window and several predefined windows
that capture and display different kinds of data. The following sections briefly
describe these windows and the pop-up menu, which is available from any
debugger window.

For more information, choose Overview from the Help menu, then choose
Debugger Windows and Menus.

1.3.1 Debugger Main Window

The debugger’s main window (see Figure 1-2) includes a menu bar, a status
region, and four buttons that are labeled Go, Step, Examine, and Stop.

~ Figure 1-2 Debugger Main Window

ﬁ VAX DEBUG: Copyright 1@ Digital Cquipment Corporation. 1989, all Rights Reserved

File Edit Control Data Customize T Help ]

@Jm Current Entity:  |[(no current entity)
Lﬁj&] Call Frame: 0] (EIGHTQUEENS)
Visible Process: |i (JONES_Twad)

I Go I l Step | lExaminel | Stop I

2K~0964A-0F

¢ Figure 1-3 shows the menus on the main window’s menu bar. Figure 1-4
and Figure 1-5 show the submenus of the Data and Customize menus,
respectively. Table 1-1 summarizes the functions of these menus and
submenus.

¢ Table 1-2 summarizes the type of information displayed in the status region
fields and the functions of the associated arrow buttons.

¢ Table 1-3 summarizes the functions of the Go, Step, Examine, and Stop
buttons.

Note that the functions of the Go, Step, and Examine buttons can also be
performed through other means, such as the pop-up menu, Control menu, or
Data menu.

1-6
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Figure 1-3 Main Window Pull-Down Menus
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Figure 1-4 Data Menu and Submenus
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Figure 1-5 Customize Menu and Submenus
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Table 1-1 Main Window Pull-Down Menus

Menu

Description

File
Edit

Control

Data

Customize

Help

End the debugging session.

Copy text to the clipboard, or paste text from the clipboard to a debugger
dialog box or the COMMAND box.

Start, stop, and monitor the execution of your program under debugger
control. For example: execute to the next line or to the next VAX
assembly-language instruction; set breakpoints, tracepoints, and
watchpoints; call a routine. For vectorized programs, force synchronization
between the scalar and vector processors.

Display or manipulate data that is associated with your program. For
example: examine variables and arbitrary program locations; assign
new values to variables; evaluate language expressions; control access
to variable names, routine names, and other symbols; manipulate
multiprocess programs and tasking (multithread) programs. Note that
the Tasks menu item is dimmed unless you are debugging a VAX Ada
program or a program written in any language that uses DECthreads
tasking services.

Tailor your debugging environment and establish default conditions.
For example: create and manipulate debugger windows; change the
programming language context; establish defaults for manipulating
data and for accessing symbols; open the COMMAND box to access the
debugger’s command interface.

Obtain conceptual and task-oriented information about the debugger. This
is an alternative to obtaining context-sensitive help on individual items
that are displayed on the screen (menus, buttons, dialog boxes, and so on).

1-8
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Table 1-2 Main Window Status Region
Label Description

Current Entity Identifies the last entity that was examined or whose value was
changed (for example, a variable or a code location). Use the
arrow buttons to display consecutive logical entities—for example,
consecutive elements of an array variable.

Call Frame Identifies the routine that the debugger uses as reference when
displaying source code in the source window or instructions in
the instruction window, or when searching for symbols that are
associated with your program (variable names, routine names, and
so on). Use the arrow buttons to reset the reference to another call
frame on the call stack.

Visible Process For a one-process program, identifies the process that is running
the program. For a multiprocess program, identifies the process
that is currently the context for entering process-specific commands.
Use the arrow buttons to reset the visible process to another process
that is under debugger control.

Table 1-3 Main Window Buttons

Button Description
Go Start execution from the current program location.
Step Execute the program one step unit of execution. By default, this is one

executable line of source code.

Examine Display the value of a variable or other entity whose name is selected in a
window, or the value of the entity last examined, if no text was selected.

Stop Interrupt program execution or a debugger operation without ending the
debugging session.

1.3.2 Debugger Predefined Windows

The debugger provides the following predefined windows that you can use to
capture and display different kinds of data:

SRC, the predefined source window

OUT, the predefined output window

AUTO, the predefined automatic window (a special output window)
INST, the predefined instruction window

REG, the predefined register window

Of these windows, only SRC and OUT are displayed, by default, at debugger
startup.

The basic features of the predefined windows are described in the next sections.
You can change certain characteristics of these windows, such as buffer size

or window attributes. You can also create additional windows similar to the
predefined windows. For more information, choose Overview from the Help menu,
then choose Debugger Windows and Menus, then choose Debugger Predefined
Windows (SRC, OUT, INST, REG, AUTO).
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1.3.2.1 Predefined Source Window (SRC)

You can use window SRC to display source code in two basic ways:

¢ By default, SRC automatically displays the source code for the module
in which execution is currently suspended. This enables you to quickly
determine your current debugging context.

¢ In addition, you can use SRC to display the source code for any part of your
program.

The name of the module whose source code is displayed is shown at the right
of the window name, SRC. The numbers displayed at the left of the source code
are the compiler-generated line numbers, as they might appear in a compiler-
generated listing file.

The next paragraphs describe the behavior of SRC when it is displaying the
current location. Section 1.5.5 explains how to display source code in arbitrary
locations.

As you execute the program under debugger control, window SRC is updated
automatically whenever execution is suspended. The boxed line indicates the
next line to be executed.

If the debugger cannot locate source lines for the routine in which execution is
suspended (because, for example, the routine is a run-time library routine), it
tries to display source lines in the next routine down on the call stack for which
source lines are available. If the debugger can display source lines for such a
routine, it issues the following message:

$DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC.
Displaying source in a caller of the current routine.

In such cases, the boxed line in the source window identifies the line to which
execution returns after the routine call. Depending on the source language and
coding style, this might be the line that contains the call statement or the next
line.

If your program was optimized during compilation, the source code displayed in
window SRC might not always represent the code that is actually executing. The
predefined instruction window INST is useful in such cases, because it shows the
exact VAX instructions that are executing. See Section 1.3.2.4.

1.3.2.2 Predefined Output Window (OUT)
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Window OUT is a general purpose output window. By default, it displays the
following information:

* Any debugger output that is not directed to windows SRC, INST, or AUTO.
For example, if window INST is not displayed or does not have the instruction
attribute, any output that would otherwise update window INST is displayed
in window OUT.

¢ Debugger diagnostic messages. Messages with a severity level greater than I
(informational) are also displayed in a message box (see Section 1.5.2).

Note that, when displaying variable names, routine names, and other symbolic
address expressions, the debugger adds a path name prefix to the name. The
path name prefix identifies the nesting program elements in which the entity was
declared in the program. For example, if you examined a variable K, whose value
was 26, in routine SWAP of module SWAP_PACK, the debugger might display the
following output:
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SWAP_PACK\SWAP\K: 26 :
In this case, SWAP_PACK\ SWAP\ is the path name prefix.

In most cases, you do not need to include a path name prefix when specifying
symbolic address expressions (see Section 1.5.10.2).

1.3.2.3 Predefined Automatic Window (AUTO)
Window AUTO is an automatically updating window that can be used instead

of window OUT to display the output from the following dialog boxes, which are
accessible from the Data menu:

Examine Variable
Examine Address or Register
Language Expressions

Window AUTO is created when you first click on the Display button in any one of
these dialog boxes. Thereafter, AUTO remains open until you close it.

AUTO includes a debugger command list in its definition. Every time the
debugger gains control, AUTO is updated with the output of that command
list.

When AUTO is created, its command list consists of the Examine or Evaluate
command that was generated when you clicked on the Display button, and it
displays the output of that command.

Subsequently, every time you click on the Display button in any of the three
dialog boxes listed, the debugger appends the new command generated to the
current command list and updates AUTO to display the output from the entire
command list.

1.3.2.4 Predefined Instruction Window (INST)

Window INST displays the decoded VAX assembly-language instruction stream
of your program. This is the exact code that is executing, including the effects of
any compiler optimization.

You can use INST in two basic ways:
¢ By default, INST automatically displays the instructions for the routine

in which execution is currently suspended. This enables you to quickly
determine your current debugging context.

¢ In addition, you can use INST to display the instructions for any part of your
program.

By default, INST is not displayed on the screen. To open INST, choose Window
Setups from the Customize menu. Clicking on a window layout of the Window

Setups submenu enables you to place INST next to either window SRC or window
REG.

If your program was optimized during compilation, the window layout that places
windows SRC and INST side by side enables you to readily compare the source
code and the decoded instruction stream.

See Section 1.5.6 for more information about displaying instructions.

1-11
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1.3.2.5 Predefined Register Window (REG)

Window REG displays the current values, in hexadecimal format, of the VAX
general registers (RO to R11, AP, FP, SP, and PC), the four condition code bits (C,
V, Z, and N) of the processor status longword (PSL), and as many of the top stack
values as can be displayed through the window.

The values contained in the registers are updated each time the debugger gains
control.

By default, REG is not displayed on the screen. To open REG, choose Window
Setups from the Customize menu. Clicking on the third layout of the Window
Setups submenu enables you to place REG next to window INST.

1.3.3 Using the Pop-Up Menu

The debugger’s pop-up menu (see Figure 1-6) enables you to perform several
common operations without having to pull down a menu in the main window.

Figure 1-6 Pop-Up Menu over Source Window
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For an explanation of the pop-up menu items, use the pop-up menu’s context-
sensitive help (see Section 1.5.1). All pop-up menu functions can also be
performed through other means.

To use the pop-up menu, proceed as follows:
1. Position the pointer within a debugger window.

2. Press and hold MB2 to display the pop-up menu, then drag to the desired
menu item and release MB2.

Note that the behavior of the Examine, Evaluate, and Set Break menu items
depends on whether you selected text before invoking the pop-up menu.

1.4 Getting Started with the Debugger
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This section walks you through the following basic steps with a sample program,
EIGHTQUEENS. The complete source code for the program is shown in
Section 1.7.

1. Set a breakpoint to suspend execution at a routine call statement.
2. Execute the program to the breakpoint.

3. Execute the program into the called routine.
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4. While execution is suspended within the routine, display the current value of
a variable.

5. Assign another value to the variable.
6. Display source code in the calling routine.

Figure 1-7 shows the source window, SRC, at debugger startup. Execution is
suspended at line 1 (the boxed line) of module EIGHTQUEENS.

Figure 1-7 Source Window at Debugger Startup
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1.4.1 Setting a Breakpoint

In this section, a breakpoint is set on line 60 of module EIGHTQUEENS. Line 60,
which is hidden below the window border in Figure 1-7, contains a call to routine
TRYCOL (see Figure 1-8).

Proceed as follows:
1. Scroll the source window to display line 60.

2. Double click on any part of line 60. When setting a breakpoint, you can select
any portion of a line in the source window. For example, you could select the
number 60, as shown in Figure 1-8, or the word TRYCOL. The breakpoint
would be set on line 60 in either case.

3. Choose Set Break from the pop-up menu.
A breakpoint is now set on line 60—specifically, at the beginning of line 60, before
the call to routine TRYCOL is executed.

1.4.2 Executing the Program to the Breakpoint

To execute the program from the current location (line 1) to the breakpoint at line
60, click on the Go button in the main window.

When execution reaches the breakpoint, the source window is updated
automatically: line 60 is boxed, indicating that execution is now suspended
at the call statement to routine TRYCOL (see Figure 1-9).

1-13
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Figure 1-8 Setting a Breakpoint with the Pop-Up Menu
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Whenever the source window is updated as a result of program execution, the
boxed line indicates the line to be executed next.

1.4.3 Executing the Program into a Called Routine
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While execution is suspended at line 60, at the call statement to routine TRYCOL,
choose Step Into Routine from the pop-up menu to execute the program one step
unit into the routine (see Figure 1-10).

After this Step command has been entered, the source window is updated,
showing that execution is now suspended at line 36, within routine TRYCOL (see
Figure 1-11).

The Step command is used in this section and the next to execute the program
one source line at a time. Note that, in this mode of operation, the Step command
executes one or more executable lines at a time, skipping over any other lines.
Executable lines are those for which instructions were generated by the compiler.
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Figure 1-10 Stepping into a Called Routine
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1.4.4 Displaying the Current Value of a Variable

The value of the Boolean variable SAFE is obtained in this section. It is obtained
after the assignment statement at line 39, in routine TRYCOL, has been executed
(see Figure 1-11).

To execute the program from the current location at line 36 past line 39 (for
example, to line 42), click on the Step button repeatedly until line 42 is boxed (see
Figure 1-12).

To display the current value of the variable SAFE, proceed as follows:
1. Double click on the word SAFE in the source window to select that word.
2. Choose Examine from the pop-up menu.

The value of SAFE (True) is now displayed in window OUT. The debugger
displays the variable name using its full path name (EIGHTQUEENS\ SAFE),
indicating that SAFE is declared in module EIGHTQUEENS.

Note that the Current Entity field in the main window is now updated to identify
the last entity that was examined, namely the variable SAFE,
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Figure 1-12 Examining a Selected Variable with the Pop-Up Menu
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1.4.5 Assigning a Value to the Variable

Assume that the variable SAFE is still selected in the source window. To change

the value of SAFE from True to False, proceed as follows (see Figure 1-13):

1. Choose Variables from the Data menu in the main window, then choose
Deposit into Variable... from the submenu.

When the Deposit into Variable dialog box is displaye&, note that the selected
word, SAFE, fills the Variable text-entry field. Thus, you do not have to enter
the variable name from the keyboard.

2. Enter the word False in the Language Expression field. This is the value to
be assigned to (deposited into) the variable.

3. Click on OK or Apply.

Variable SAFE now has the value False. You can verify this by choosing Examine
from the pop-up menu.
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Figure 1-13 Assigning a Value to a Variable
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1.4.6 Displaying Source Code for the Calling Routine

By default, the source window shows the source code for the routine in which
execution is suspended, and the name of the routine is identified in the Call
Frame field of the main window.

In this example, execution is currently suspended within routine TRYCOL of
module EIGHTQUEENS. The Call Frame field in Figure 1-12 displays the
routine path name, EIGHTQUEENS\ TRYCOL.

The number 0 in the Call Frame field indicates that the routine whose source
code is displayed is the routine at the top of the call stack (where execution is
suspended).

If, as in this example, execution is suspended within a called routine, you can
display the source code for the calling routine by clicking once on the Call Frame
down arrow button.

Clicking once displays the source code for routine EIGHTQUEENS (the main
program), as shown in Figure 1-14. The boxed line identifies the line where
execution will continue in that routine (line 61, which follows the call statement).
The Call Frame field now displays the number 1, followed by the name of that
routine. The number indicates the level, relative to the top of the call stack (level
0), of the routine whose source code is displayed.
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Figure 1-14 Displaying Source Code in the Calling Routine
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In general, clicking on the Call Frame arrow buttons enables you to display the
source code for any routine up or down the call stack.

A Call Frame arrow button that is dimmed indicates that the scope reference is
at the end of the call stack.

1.5 Using the Debugger

The remaining sections of this chapter explain how to use the debugger to
perform basic functions. After an introduction, most sections point to an online
help topic for additional information.

1.5.1 Displaying Online Help About the Debugger
Note
When you first invoke the debugger’s online help system, it might take

up to a minute to display the first help topic. Subsequent help topics are
displayed within a few seconds after you request them.

Three kinds of online help about the debugger and debugging are available during
a debugging session:

¢ Context-sensitive help, which is available for any item in a debugger window,
menu, or dialog box

* Conceptual and task-oriented help, which consists of an introductory help
topic named Overview and several subtopics on specific subjects

¢ Help about the debugger’s command interface, which is available through the
COMMAND box

The technique for displaying each kind of online help is described in the following
sections.
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1.5.1.1 Displaying Context-Sensitive Help

Context-sensitive help about the debugger is available for any item in a debugger
window, menu, or dialog box.

To display context-sensitive help:

1. Point to an item.

2. Press and hold the Help key.

3. Click on either MB1, MB2, or MB3.

4. Release the Help key.

Context-sensitive help for dialog boxes is structured in the following way:

* The same help text is displayed for any location of the pointer within a dialo
box. :

* The introductory help text describes how to use the dialog box for a typical
operation.

* In most cases, a separate additional topic is devoted to each item in the dialog
box (button, menu, and so on). These topics are listed in the order that the
items they describe appear in the dialog box, from top to bottom.

* Other topics provide task-oriented and conceptual discussions, where
applicable.

When using context-sensitive help, you should also display the Overview help
topic and look for related information in the list of additional topics.

1.5.1.2 Displaying the Overview Help Topic and Subtopics

The Overview help topic and subtopics provide conceptual and task-oriented help
about the debugger and debugging. These topics supplement the information that
is available through context-sensitive help.

To display the Overview topic, use any one of the following techniques:
¢ Choose Overview from the Help menu in the main window.

* Ensure that a debugger window has the input focus, then press and release
the Help key.

¢ Choose Go To Overview from the View menu of a debugger help window.

Then, to obtain information about a particular subject, choose a topic from the
list of additional topics.

1.5.1.3 Displaying Help About the Debugger’s Command Interface
Help about the debugger’s command interface is available through the

COMMAND box.
* To open the COMMAND box, choose Show Command... from the Customize
menu.

* To list the help topics, enter the HELP command at the DBG> prompt.

¢ TFor an explanation of the command-interface help system, enter the command
HELP HELP.

1-19



Introduction to the Debugger: DECwindows Interface
1.5 Using the Debugger

1.5.2 Debugger Diagnostic Messages

Debugger diagnostic messages include numerous informational messages (severity
level I) that provide feedback during a debugging session. (For an explanation

of severity levels, choose Overview from the Help menu, then choose Debugger
Diagnostic Messages.)

To reduce the time involved in acknowledging informational messages, only those
debugger messages that have severity levels of W, E, or F are displayed in a
message box.

You can get context-sensitive help on any debugger message that is displayed in a
message box.

By default, all debugger messages (including those of severity level I) are
displayed in window OUT. Thus, debugger messages of severity level greater than
I are displayed both in a message box and in window OUT.

Messages displayed in a message box show only the message text. Messages
displayed in window OUT show the message text, identifier, severity, and facility.

1.5.3 Interrupting Program Execution and Aborting Debugger Operations

To interrupt program execution during a debugging session, click on the Stop
button in the main window. This is useful if, for example, the program is in an
infinite loop.

To abort a debugger operation that is in progress, click on the Stop button in the
main window. This is useful if, for example, the debugger is displaying a long
stream of data.

Clicking on the Stop button does not end the debugging session. Clicking on
the Stop button when the program is not running or when the debugger is not
performing an operation has no effect.

1.5.4 Ending a Debugging Session
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To end a debugging session, choose either Exit or Quit from the File menu in the
main window.

If your program has application-declared exit handlers, Exit executes these
handlers. Quit gives you the option of executing application-declared exit
handlers (a dialog box is displayed in such cases).

Unless you are debugging a multiprocess program, you can also end the
debugging session by choosing Exit or Quit from any debugger window (not
just the main window).

For multiprocess programs, choosing Exit or Quit from a debugger window other
than the main window has the following effect:

* If the window is not process specific, terminates the visible process

¢ If the window is process specific, terminates the process associated with that
window

The following message, displayed in the output window during a debugging
session, indicates that your program has completed normally:

%¥DEBUG-I-EXITSTATUS, is ‘$%SYSTEM-S-NORMAL, normal successful completion’
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If you want to continue debugging after seeing this message, it is usually best to
end the session and start a new one. You can restart execution from within the
debugging session (by choosing Go... from the Control menu and then specifying
a location in the Go dialog box). However, this technique can produce unexpected
results if, for example, some variables have different values from when you first
ran the program.

1.5.5 Displaying Source Code

By default, window SRC automatically displays the source code for the module in
which execution is currently suspended.

In addition, window SRC has the source attribute by default. Therefore, you can
also use SRC to display the source code for any part of your program (if source
code is available for display):

* You can display the source code for any routine on the call stack by clicking
on the Call Frame arrow buttons in the main window.

The number shown in the Call Frame field indicates the relative level of the
routine on the call stack. Call frame 0 denotes the routine at the top of the
call stack, where execution is suspended. Call frame 1 denotes the calling
routine, and so on.

¢ You can display arbitrary source lines in any module by choosing View
Source... from the Commands menu of window SRC.

* You can display the source line associated with a code location (for example, a
routine declaration) by choosing Examine Code... from the Code submenu of
the Data menu.

After manipulating the contents of window SRC, you can display the location at
which execution is suspended by choosing View Current Location from the pop-up
menu.

If the debugger cannot locate source lines for display, it issues a diagnostic
message.

For more information, choose Overview from the Help menu, then choose
Displaying Source Code.

1.5.6 Displaying Decoded VAX Instructions

By default, window INST automatically displays the decoded instruction stream
for the routine in which execution is currently suspended.

If window INST has the instruction attribute, it is also updated by any command
that you enter to display instructions. If no window has the instruction attribute,
the output of such commands is directed at window OUT. Note that opening
window INST through the Window Setups submenu of the Customize menu
automatically assigns the instruction attribute to that window.

You can display instructions in window INST as follows:

¢  You can display the instruction stream for any routine that is on the call
stack by clicking on the Call Frame arrow buttons in the main window.

¢ You can display the instructions that are associated with a code location
(for example, a routine declaration) by choosing View Instructions from the
Commands menu of window INST, or by choosing Examine Code... from the
Code submenu of the Data menu.
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When you choose Examine Code..., you have the option of displaying detailed
information about the instruction operands.

After manipulating the contents of window INST, you can display the location at
which execution is suspended by choosing View Current Location from the pop-up
menu.

For more information, choose Overview from the Help menu, then choose
Displaying Decoded VAX Instructions.

1.5.7 Specifying Address Expressions in Dialog Boxes

Several dialog boxes (for example, the Break dialog box) require you to enter an
address expression. An address expression is an entity that denotes a memory
address or a register. Do not confuse an address expression with a language
expression, which denotes a value (see Section 1.5.9.4).

The debugger is a symbolic debugger. Therefore, although you can specify a
memory address or register directly in a dialog box, you usually specify symbolic
address expressions. These include routine names, variable names, program
labels, and source line numbers. The debugger associates a symbolic address
expression with a unique memory address, range of addresses, or register. The
debugger also recognizes the compiler-generated type that is associated with a
symbolic address expression.

Address expressions are associated with either code (VAX assembly-language
instructions) or data. The kind of address expression you need to specify in a
dialog box depends on the action you are about to perform and is indicated in the
help text for that dialog box. For example, when setting a breakpoint, you specify
an address expression that is associated with code; when setting a watchpoint,
you specify an address expression that is associated with data (a variable name,
in most cases).

You can fill the Address Expression field of a dialog box in two ways:

* By selecting text in a window. If you select the text before you open the dialog
box, the text is automatically inserted in the Address Expression field.

* By entering text directly from the keyboard.

The help text for a dialog box explains the conventions for filling the Address
Expression field. '

For more information, choose Overview from the Help menu, then choose
Specifying Address Expressions.

1.5.8 Controlling and Monitoring Program Execution
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This section explains how to perform the following tasks:

¢ Start or resume program execution

¢ Execute the program to the next source line, instruction, or other step unit
¢ Use breakpoints to suspend execution at points of interest

¢ Use tracepoints to trace the execution path of your program through specified
locations

¢ Use watchpoints to monitor changes in the values of variables
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To determine where execution is suspended at any time during a debugging
session, use the techniques described in Section 1.5.5 and Section 1.5.6. You can
also choose Call Stack... from the Data menu to display the sequence of routine
calls that are currently active on the call stack and to obtain detailed information
about the call stack.

1.5.8.1 Starting or Resuming Program Execution
Use the Go command to start or resume program execution.

To start execution from the current location, click on the Go button in the main
window.

To start execution from another location, choose Go... from the Control menu and
specify the location in the Go dialog box.

After it is started with the Go command, program execution continues until one
of the following events occurs:

¢ The program completes execution

* A breakpoint is reached

¢ A watchpoint is activated

* An exception is signaled

*  You click on the Stop button in the main window

For more information, choose Overview from the Help menu, then choose Starting
and Resuming Execution (Go Command).

1.5.8.2 Executing the Program by Step Unit
Use the Step command to execute the program one or more step units at a time.

By default, a step unit is one line of source code; and, by default, the debugger
notifies you of the completion of a Step command by displaying a "stepped
to ... " message and the source line where execution is suspended.

To execute one step unit, click on the Step button in the main window.

You can use the pop-up menu for some common step options (for example, step
into routine, step by instruction).

To execute these and other step options, or to change the step unit or any Step
command default, choose Step... from the Control menu. For example, you can
make the default step unit signify "execute one instruction".

For more information, choose Overview from the Help menu, then choose
Executing the Program by Step Unit (Step Command).

1.5.8.3 Suspending and Tracing Execution with Breakpoints and Tracepoints

A breakpoint is a location in your program at which execution is to be suspended.
Typical locations are routine declarations, program labels, and specific lines of
source code. At a breakpoint, you can step into a routine, check the current value
of a variable, and so on.

In addition to specifying unique locations, you can set breakpoints on every source
line or on certain classes of VAX assembly-language instructions. You can also
set breakpoints on certain kinds of events, such as exceptions and tasking events.
And you can set conditional breakpoints that trigger only when a specified
expression is evaluated to be true.
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A tracepoint is like a breakpoint, except that execution continues after the
debugger reports that the tracepoint has been reached. Tracepoints enable you
to monitor the path of execution of your program through specified locations (for
example, through routine calls). As with breakpoints, you can trace through
classes of instructions, monitor events, and set conditional tracepoints.

In general, to set, identify, or cancel breakpoints or tracepoints, choose Break...
from the Control menu. '

For more information, choose Overview from the Help menu, then choose Using
Breakpoints and Tracepoints.

1.5.8.4 Monitoring Changes in Variables with Watchpoints

A watchpoint is a memory address, register, or (typically) a variable declared in
the program whose value is monitored during program execution. If the value
changes, the debugger suspends execution and reports the old and new values.

Note that you can set a watchpoint on a nonstatic (stack or register) variable only
when program execution is currently suspended within the scope of its defining
routine—that is, when the defining routine is active on the call stack.

To set, identify, or cancel watchpoints, choose Watch... from the Control menu.
As with breakpoints and tracepoints, you have several options for setting
watchpoints.

For more information, choose Overview from the Help menu, then choose Using
Watchpoints. \

1.5.9 Examining and Manipulating Program Data
The debugger enables you to manipulate variables declared in your program, code
locations (locations containing VAX instructions), memory addresses, registers,
and language expressions.

1.5.9.1 Operations with Variables
To manipulate variables in your program, choose Variables from the Data menu.
The Variables submenu provides the following operations:
¢ To display the value of a variable, choose Examine Variable...
¢ To assign a value to a variable, choose Deposit into Variable...

¢ To display information about a variable, such as its type, memory address or
register, and path name, choose Show Variable...

Note that you can examine a nonstatic (stack or register) variable only when
program execution is currently suspended within the scope of its defining
routine—that is, when the defining routine is active on the call stack.

For more information, choose Overview from the Help menu, then choose
Examining and Manipulating Program Data, then choose Operations with
Variables.

1.5.9.2 Operations with Code Locations

To manipulate code locations in your program (locations with VAX assembly-
language instructions) choose Code from the Data menu. The Code submenu
provides the following operations:

¢ To display the following information, choose Examine Code...

— The source line for a code location (for example, for a routine declaration).
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— The VAX instructions at a code location (for example, the instruction
at the current PC value, where execution is suspended). The program
counter (PC) is a VAX register that contains the address of the instruction
to be executed next.

* To deposit a VAX instruction at a memory address or into a register, choose
Deposit Code...

¢ To display the memory address of a routine, line number, or other code
location, choose Show Address...

For more information, choose Overview from the Help menu, then choose
Examining and Manipulating Program Data, then choose Operations with Code
Locations.

See also Section 1.3.2.4 and Section 1.5.6 for information about displaying
instructions associated with your program.

1.5.9.3 Operations with Addresses or Registers
To manipulate memory addresses or registers, choose Addresses or Registers
from the Data menu. The Addresses or Registers submenu provides the following
operations:

¢ To display the value stored at an address or in a register, choose Examine
Address or Register...

* To change the value stored at an address or in a register, choose Deposit into
Address or Register...

¢ To display the symbol (if any) that is associated with an address or register,
choose Symbolize Address or Register...

For more information, choose Overview from the Help menu, then choose
Examining and Manipulating Program Data, then choose Operations with
Addresses or Registers.

1.5.9.4 Evaluating Language Expressions

To evaluate a language expression, choose Language Expressions... from the Data
menu.

The debugger recognizes the operators and expression syntax of the currently set
language. For example, if your program has an integer variable named WIDTH,
you can use the Language Expressions dialog box to evaluate the expression
WIDTH + 7. The debugger adds 7 to the current value of WIDTH and displays
the result.

For more information, choose Overview from the Help menu, then choose
Specifying and Evaluating Language Expressions. See also Section 1.5.13 for
information about debugging multilanguage programs.

1.5.10 Controlling Access to Symbols in Your Program

To have full access to the symbols that are associated with your program (variable
names, routine names, source code, line numbers, and so on), you must compile
and link the program using the /DEBUG qualifier, as explained in Section 1.2.1.

Under these éonditions, the way in which the debugger handles these symbols
is transparent to you, in most cases. However, the following two areas might
require action:

¢ Setting and canceling modules
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* Resolving symbol ambiguities

These two subjects are discussed in the next sections. For more information,
choose Overview from the Help menu, then choose Controlling Access to Symbols
in Your Program.

1.5.10.1 Setting and Canceling Modules

To facilitate symbol searches, the debugger loads symbol information from the
executable image into a run-time symbol table (RST), where that information can
be accessed efficiently. Unless symbol information is in the RST, the debugger
does not recognize or properly interpret the associated symbols. '

Because the RST takes up memory, the debugger loads it dynamically,
anticipating what symbols you might want to reference in the course of program
execution. The loading process is called module setting, because all symbol
information for a given module is loaded into the RST at one time.

At debugger startup, only the module containing the image transfer address
is set. Subsequently, whenever execution of the program is interrupted, the
debugger sets the module that contains the routine in which execution is
suspended. This enables you to reference the symbols that should be visible
at that location.

If you try to reference a symbol in a module that has not been set, the debugger
warns you that the symbol is not in the RST. For example:

$DEBUG-W-NOSYMBOL, symbol ‘X’ is not in symbol table

You must then set the module containing that symbol explicitly. To set a module,
choose Modules... from the Data menu. The Modules dialog box lists the modules
of your program and identifies which modules are set.

For more information, choose Overview from the Help menu, then choose
Controlling Access to Symbols in Your Program, then choose Seiting and
Canceling Modules.

1.5.10.2 Resolving Symbol Ambiguities
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Symbol ambiguities can occur when a symbol (for example, a variable name X) is
defined in more than one routine or other program unit.

In most cases, the debugger resolves symbol ambiguities automatically. First

it uses the scope and visibility rules of the currently set language. In addition,
because the debugger permits you to specify symbols in arbitrary modules (to set
breakpoints and so on), the debugger uses the ordering of routine calls on the call
stack to resolve symbol ambiguities.

In some cases, however, the debugger might respond as follows when you specify
a symbol that is defined multiple times:

* It might issue a "symbol not unique" message because it is not able to
determine the particular declaration of the symbol that you intended.

* It might reference a symbol declaration other than the one you want.

To resolve such problems, you must specify a scope where the debugger should
search for the particular declaration of the symbol. There are two techniques:

¢ Specify a path name prefix with the symbol. For example, if the variable
X is defined in two modules named COUNTER and SWAP, the path name
SWAP\X uniquely specifies the declaration of X in module SWAP. This
technique can always be used to resolve symbol ambiguities.
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¢ If the different declarations of the symbol are within routines that are
currently active on the call stack, use the Call Frame arrow buttons in the
main window to reset the reference for looking up symbols to the appropriate
call frame. With this technique you do not need to specify a path name prefix.

For more information, choose Overview from the Help menu, then choose
Controlling Access to Symbols in Your Program, then choose Resolving Symbol
Ambiguities.

1.5.11 Using the Debugger’s Command Interface

The debugger is available in a command interface that runs on terminals and
workstations (see Part II of this manual). When using that interface, you interact
with the debugger by entering commands at the debugger prompt (DBG>).

When using the debugger’s DECwindows interface, you can open the COMMAND
box, which enables you to enter debugger commands at the DBG> prompt:

¢ To open the COMMAND box for just one command, press the DO key.

¢ To open the COMMAND box indefinitely, choose Show Command... from

the Customize menu. Choosing Hide Command from that menu closes the
COMMAND box.

You can also enter debugger commands in debugger command procedures
and initialization files for execution under the DECwindows environment (see
Section 1.5.12).

The following commands are disabled in the debugger’s DECwindows interface:

CANCEL WINDOW

EXPAND

MOVE

SELECT/PROGRAM

SET MARGINS

SET MODE NOSCREEN

SET OUTPUT [NOJSCREEN_LOG
SET OUTPUT [NOITERMINAL
SET TERMINAL

SET WINDOW

SHOW MARGINS

SHOW TERMINAL

SHOW WINDOW

The debugger issues an error message when you try to enter any of these
commands interactively from the COMMAND box or when the debugger executes
a command procedure containing any of these commands.

For more information, choose Overview from the Help menu, then choose Using
the Debugger’s Command Interface.

1.5.12 Using Log Files, Initialization Files, and Command Procedures

When you use the debugger’s DECwindows interface, each of your actions
results in one or more debugger commands. These commands are echoed in the
COMMAND box by default.

You can record in a log file the debugger commands that you enter directly or
indirectly during a debugging session and the debugger’s responses to those
commands. You can use log files to keep a record of your debugging sessions,
or you can use them as command procedures in subsequent sessions. For more
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information, choose Overview from the Help menu, then choose Logging a
Debugging Session into a File.

You can create an initialization file containing debugger commands to set your
default debugging modes, debugger window characteristics, and so on. When you
invoke the debugger, those commands are executed automatically to tailor your
debugging environment. For more information, choose Overview from the Help
menu, then choose Using a Debugger Initialization File.

You can direct the debugger to execute a command procedure (a file containing
a sequence of debugger commands) to re-create a debugging session, to continue
a previous session, or to avoid typing the same debugger commands many times
during a debugging session. You can pass parameters to command procedures.
For more information, choose Overview from the Help menu, then choose Using
Debugger Command Procedures.

1.5.13 Debugging Multilanguage Programs

Within the same debugging session, you can debug modules whose source code is
written in different languages.

By default, the debugger language remains set to the language of the main
program throughout the debugging session, even if execution is suspended
within a module written in another language. To take full advantage of symbolic
debugging with such modules, you can set the debugging context to another
language by choosing Language from the Customize menu.

For more information, choose Overview from the Help menu, then choose '
Debugging Multilanguage Programs and Debugger Support for Languages.

When debugging in any language, be sure also to consult the documentation
supplied with that language.

1.5.14 Debugging Shareable Images

By default, the main (executable) image of your program is your debugging
context.

By setting your debugging context to a shareable image that is linked with your
program, you have access to the symbols declared in that image. To set your
debugging context to another image, choose Images... from the Data menu.

For more information, choose Overview from the Help menu, then choose
Debugging Shareable Images.

1.5.15 Debugging Tasking (Multithread) Programs
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Tasking programs have multiple threads of execution within a VMS process.
Examples of such programs are programs that use DECthreads or POSIX 1003.4a
services, and programs that use language-specific tasking services (for example,
Ada tasking programs).

When using the debugger with a tasking program, you can control the execution
of individual tasks and display information about one or more tasks or the entire
tasking system.

To manipulate tasks, choose Tasks... from the Data menu. See also Chapter 12 of
this manual.
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1.5.16 Debugging Multiprocess Programs

To debug a multiprocess program (a program that runs in more than one process),
you must establish a multiprocess debugging configuration before invoking the
debugger. That configuration enables you to interact with several processes from
one debugging session.

Enter the following command to establish a multiprocess debugging configuration:
$ DEFINE/JOB DBGSPROCESS MULTIPROCESS

After you have invoked the debugger, you can control the execution of individual
processes, examine data associated with specific processes, display information in
process-specific windows, and so on.

To manipulate processes, choose Processes... from the Data menu. For more
information, choose Overview from the Help menu, then choose Debugging
Multiprocess Programs. '

1.5.17 Debugging Vectorized Programs

When using the debugger with a vectorized program (a program that uses VAX
vector instructions), you can perform tasks such as the following:

¢ Control and monitor the execution of vector instructions with breakpoints,
watchpoints, and so on

* Examine and deposit into the vector control registers (VCR, VLR, and VMR)
and the vector registers (VO to V15)

* Examine and deposit vector instructions and their operands

¢ Perform masked operations on vector registers to display only certain register
elements or override the masking associated with a vector instruction

* Control synchronization between the scalar and vector processors
For more information, choose Overview from the Help menu, then choose
Debugging Vectorized Programs.

1.5.18 Using the Keypad to Enter Commands

When you invoke the debugger, a few commonly used debugger command
sequences are automatically assigned to the keys on the numeric keypad (to the
right of the main keyboard). Thus, you can perform certain functions either by
choosing an item from a menu or by pressing a keypad key.

The predefined key functions are identified in Figure 1-15.
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Figure 1-15 Keypad Key Functions Predefined by the Debugger—DECwindows

Interface
(" PF1 PF2 PF3 PF4 )
GOLD HELP DEFAULT | SET MODE SCREEN BLUE
GOLD HELPGOLD | SET MODE NOSCR BLUE
GOLD HELP BLUE DISP/GENERATE BLUE
7 8 9 -
DISP SRCINST,OUT|  SCROLLUP DISPLAY next DISP next at FS
DISP INST,REGOUT|  SCROLL/TOP SET PROC next
DISP2SRC, 2INST |  SCROLL/UP... DISP 2 SRC DISP SRC, OUT
4 5 6 ’
SCROLLLEFT EX/SOU .0%PC | SCROLLURIGHT Go
SCROLULEFT255 | SHOWCALLS | SCROLURIGHT:255 | SEL/SOURCE next
SCROLULEFT.. | SHOWCALLS3 |SCROLLRIGHT.. | SEL/INST next
1 2 3 ENTER
EXAMINE SCROLUDOWN | SEL SCROLL next
EXAMA(prev) SCROLL/BOTTOM | SEL OUTPUT next
DISP 3 SRC, 3INST | SCROLUDOWN... | DISP3 SRC
ENTER
0
STEP RESET
STEPINTO RESET
STEPIOVER RESET
N /

ZK-0957A-GE

Most keypad keys have three predefined functions—DEFAULT, GOLD, and
BLUE.

* To enter a key’s DEFAULT function, press the key.

* To enter its GOLD function, first press and release the PF1 (GOLD) key, and
then press the key.

¢ To obtain its BLUE function, first press and release the PF4 (BLUE) key, and
then press the key.

In Figure 1-15, the DEFAULT, GOLD, and BLUE functions are listed within each
key’s outline, from top to bottom, respectively. For example:

* Pressing keypad key 0 enters the STEP command (like clicking on the Step
button in the main window).

* Pressing key PF1 and then keypad key 0 enters the STEP/INTO command
(like choosing Step Into Routine from the pop-up menu).

¢ Pressing key PF4 and then keypad key 0 enters the STEP/OVER command
(like choosing Step Over routine from the pop-up menu).

You can redefine keypad key functions.
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For more information, choose Overview from the Help menu, then choose
Entering Debugger Commands from the Keypad.
1.6 Additional Options for Invoking the Debugger

Section 1.2 describes how to compile and link your program prior to debugging,
establish the default debugging configuration for one-process programs, and
invoke the debugger in the usual way from a DECterm window.

The sections that follow describe other options for invoking the debugger:
* Invoke the debugger from a FileView window
¢ Interrupt a program that is executing freely and then invoke the debugger

* Override the debugger’s default (DECwindows) interface to achieve the
following:

— Display the debugger’s DECwindows interface on another workstation

— Display the debugger’s command interface in a DECterm window, along
with any program input/output

— Display the debugger’s command interface and program input/output in
separate DECterm windows

In all cases, before invoking the debugger, first compile and link the modules of
your program and establish the appropriate debugging configuration as explained
in Section 1.2.1, Section 1.2.2, and Section 1.5.16.

Note

You cannot run a program under debugger control over a DECnet link.
Both the image to be debugged and the debugger must reside on the same
node.

For more information, including details on compilation and linking options that
affect debugging, choose Overview from the Help menu, then choose Options for
Invoking the Debugger.

1.6.1 Invoking the Debugger from a FileView Window
To invoke the debugger from a FileView window, proceed as follows:

1. Choose Run from the FileView Files menu. A dialog box is displayed.
2. Specify the executable image file to be debugged.

3. Choose the Debug option.

4. Click on OK.

1.6.2 Invoking the Debugger with the DCL DEBUG Command

You can invoke the debugger while your program is executing freely (for example,
if you suspect that the program might be in an infinite loop or if you see erroneous
output).

To invoke the debugger in this manner, proceed as follows:

1. Enter the DCL command RUN/NODEBUG to execute the program without
debugger control.
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2. Press Ctrl/Y to interrupt the executing program. Control then passes to the
DCL command interpreter.

3. Enter the DCL command DEBUG to activate the debugger. When the
debugger comes up, it displays the main, source, and output windows, sets
the language-dependent parameters to the language of the module where
execution was interrupted, and executes any user-defined initialization file.

For example:

$ PASCAL/DEBUG/NOOPTIMIZE EIGHTQUEENS
$ LINK/DEBUG EIGHTQUEENS
$ RUN/NODEBUG EIGHTQUEENS

CtrlrY

Interrupt
$ DEBUG

[invokes debugger]

To help you identify where execution was interrupted, look at the source window
and choose Call Stack... from the Data menu to identify the sequence of routine
calls on the call stack.

1.6.3 Overriding the Debugger’s Default Interface

By default, if your workstation is running VMS DECwindows, the debugger comes
up in the DECwindows interface on the workstation specified by the DECwindows
application-wide logical name DECW$DISPLAY.

This section explains how to override the debugger’s default DECwindows
interface to achieve the following:

* Display the debugger’s DECwindows interface on another workstation

¢ Display the debugger’s command interface in a DECterm window, along with
any program input/output

* Display the debugger’s command interface and program input/output in
separate DECterm windows

The logical name DBG$DECW$DISPLAY enables you to override the default
interface of the debugger. Note that, in most cases, there is no need to define
DBG$DECWS$DISPLAY, because the default implies the desired action.

Section 1.6.3.4 provides more information about the logical names
DBG$DECW$DISPLAY and DECW$DISPLAY.

1.6.3.1 Displaying the Debugger’s DECwindows Interface on Another Workstation
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If you are debugging a DECwindows application that uses most of the screen,
you might find it useful to run the program on one workstation and display the
debugger’s DECwindows interface on another. To do so, proceed as follows:

1. Enter a logical definition with the following syntax in the DECterm window
from which you plan to run the program:

DEFINE/JOB DBG$DECWSDISPLAY workstation_pathname

where workstation_pathname is the path name for the workstation where the
debugger’s DECwindows interface is to come up. See the description of the
SET DISPLAY command in the VMS DCL Dictionary for the syntax of this
path name.
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It is recommended that you use a job definition. If you use a process
definition, it must not have the CONFINE attribute.

2. Run the program from that DECterm window. The debugger’s DECwindows
interface comes up on the workstation specified by DBG$DECW$DISPLAY.
The application’s windowing interface comes up on the workstation display
where it normally does.

1.6.3.2 Displaying the Debugger’s Command Interface in a DECterm Window
To display the debugger’s command interface in a DECterm window, along with
any program input/output, proceed as follows:

1. Enter the following definition in the DECterm window from which you plan
to run the program:

$ DEFINE/JOB DBG$DECWSDISPLAY " *

You can specify one or more space characters between the quotation marks. It
is recommended that you use a job definition for the logical name. If you use
a process definition, it must not have the CONFINE attribute.

2. Run the program from that DECterm window. The debugger’s command
interface comes up in the same window.

For example:

$ DEFINE/JOB DBGSDECWSDISPLAY " "

$ PASCAL/DEBUG/NOOPTIMIZE EIGHTQUEENS
$ LINK/DEBUG EIGHTQUEENS

$ RUN EIGHTQUEENS

VAX DEBUG Version 5.5

%DEBUG-I-INITIAL, language is PASCAL, module set to EIGHTQUEENS
DBG>

You can now enter debugger commands as described in Part II of this manual,
which starts with Chapter 2.

1.6.3.3 Displaying the Command Interface and Program Input/Output in Separate DECterm
Windows
This section describes how to display the debugger’s command interface in a
separate DECterm window from the DECterm window from which you invoke the
debugger. This separate window is useful when using the command interface to
debug a screen-oriented program:

¢ The program’s input/output is displayed in the window from which you invoke
the debugger.

¢ The debugger’s input/output, including any screen-mode display, is displayed
in the separate window.

The effect is the same as entering the SET MODE SEPARATE command at the
DBG> prompt on a workstation running VWS rather than DECwindows. (The
SET MODE SEPARATE command is not valid when used in a DECterm window.)

The following example shows how to display the debugger’s command interface in
a separate debugger window titled “Debugger”.

1. Create the command procedure SEPARATE_WINDOW.COM shown in
Example 1-1.
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2. Execute the command procedure:

$ @SEPARATE WINDOW
$DCL-I-ALLOC, _MYNODE$TWA8: allocated

A new DECterm window is created with the attributes specified in
SEPARATE_WINDOW.COM.

3. Follow the steps in Section 1.6.3.2 to display the debugger’s command
interface. The interface is displayed in the new window.

4. You can now enter debugger commands in the debugger window. Program
input/output is displayed in the DECterm window from which you invoked
the debugger.

5. When you end the debugging session with the EXIT command, control returns
to the DCL prompt in the program input/output window, but the debugger
window remains open.

6. To display the debugger’s command interface in the same window as the
program’s input/output (as in Section 1.6.3.2), enter the following commands:

$ DEASSIGN/JOB DBGSINPUT
$ DEASSIGN/JOB DBGSOUTPUT

The debugger window remains open until you close it explicitly.

Example 1-1 Command Procedure SEPARATE_WINDOW.COM

$ ! Simulates effect of SET MODE SEPARATE from a DECterm window
$ !
$ CREATE/TERMINAL/NOPROCESS -
/WINDOW_ATTRIBUTES=(TITLE="Debugger",—
ICON_NAME="Debugger",ROWS=40) -
/DEFINE_LOGICAL=(TABLE=LNM$JOB,DBG$INPUT,DBG$OUTPUT)

$ ALLOCATE DBGS$SOUTPUT

$ EXIT :

$ !

$ | The command CREATE/TERMINAL/NOPROCESS creates a DECterm

$ ! window without a process.

$ !

$ ! The /WINDOW ATTRIBUTES qualifier specifies the window’s

$ ! title (Debugger), icon name (Debugger), and the number

$ ! of rows in the window (40).

$ !

$ | The /DEFINE_LOGICAL qualifier assigns the logical names

$ | DBGSINPUT and DBGSOUTPUT to the window, so that it becomes
$ ! the debugger input and output device.

$ !

$ ! The command ALLOCATE DBGSOUTPUT causes the separate window
$ ! to remain open when you end the debugging session.

1.6.3.4 Explanation of DBGSDECWS$DISPLAY and DECW$DISPLAY
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By default, if your workstation is running VMS DECwindows, the debugger comes
up in the DECwindows interface on the workstation specified by the DECwindows
application-wide logical name DECW$DISPLAY. DECW$DISPLAY is defined in
the job table by FileView or DECterm. It points to the display device for the
workstation.

For information about DECW$DISPLAY, see the description of the DCL
commands SET DISPLAY and SHOW DISPLAY in the VMS DCL Dictionary.
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The logical name DBG$DECWS$DISPLAY is the debugger-specific equivalent of
DECWS$DISPLAY. DBG$DECW$DISPLAY is analogous to the debugger-specific
logical names DBG$INPUT and DBG$OUTPUT. These enable you to reassign
SYS$INPUT and SYS$OUTPUT, respectively, to specify the device on which
debugger input and output are to appear.

The default user interface of the debugger results when DBG$DECW$DISPLAY
is undefined or has the same translation as DECW$DISPLAY. By default,
DBG$DECWS$DISPLAY is undefined.

The algorithm that the debugger follows when using the logical definitions of
DECW$DISPLAY and DBG$DECW$DISPLAY is as follows:

1. If the logical name DBG$DECW$DISPLAY is defined, then use it. Otherwise,
use the logical name DECW$DISPLAY.

2. Translate the logical name. If its value is not null (if the string contains
characters other than space characters), the DECwindows interface comes up
on the specified workstation. If the value is null (if the string consists only of
space characters), the command interface comes up in the DECterm window.

1.7 Sample Program EIGHTQUEENS

Example 1-2 is the Pascal program, EIGHTQUEENS, that is used in Section 1.4.
Line numbers correspond to the compiler assigned line numbers as displayed in a
debugger source window.

The program prints out the possible locations on a chess board at which each of
eight queens can be positioned safely, without threatening each other. A queen
can be threatened by another queen on the same row, in the same column, or
along a diagonal.

When executed, the program produces several lines of integers. For example:

15863724
16837425
17468253
17582463
24683175
25713864
37286415
38471625
41582736
41586372
82531746
83162574
84136275

Each line of output represents a possible safe configuration of the eight queens
on a standard 8-row by 8-column chess board. For example, the output line
41582736 indicates that queens can be positioned safely at rows 4, 1, 5, 8, 2, 7, 3,
and 6 of columns 1 to 8, respectively.
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Example 1-2 Sample Program EIGHTQUEENS

: PROGRAM Eightqueens (OUTPUT) ;
VAR
I : INTEGER;
A : ARRAY[1..8] OF BOOLEAN;
B : ARRAY[2..16] OF BOOLEAN;
C : ARRAY[-7..7] OF BOOLEAN;
X : ARRAY[1..8] OF INTEGER;
Safe : BOOLEAN; K: INTEGER;

1

2

3

4

5

6

7

8

9

10: PROCEDURE Print;
11: BEGIN (* Print *)
12: FOR K := 1 TO 8 DO
13 WRITE(X[K]: 2);
14 WRITELN;
15 END; (* Print *)
16

17:  PROCEDURE Trycol(J : INTEGER);

18: VAR

19: I : INTEGER;

20:

21: PROCEDURE Setqueen;
22 BEGIN (* Setqueen *)
23: A[I] := FALSE;

24: B[I+J] := FALSE;
25; C[I-J] := FALSE;
26: END; (* Setqueen *)
27:

28: PROCEDURE Removequeen;
29: BEGIN (* Removequeen *)
30: A[I] := TRUE;

31: B[I+J] := TRUE;
32: C[I-J] := TRUE;
33: END; (* Removequeen ¥*)
34:

35: BEGIN (* Trycol *)

36: I:=20;

37: REPEAT

38: I :=1I+1;

39: Safe := A[I] AND B[I+J] AND C[I-J];
40: IF Safe THEN

41: BEGIN

42: Setqueen;

43: X[J] := I;

44; IF J < 8 THEN
45: Trycol (J+1)
46: ELSE

47 Print;

48: Removequeen;
49; END;

50: UNTIL I = 8;

51: END; (* Trycol *)

(continued on next page)
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Example 1-2 (Cont.) Sample Program EIGHTQUEENS
52:

53: BEGIN (* Eightqueens *)

54: FOR I :=1 TO 8 DO

55: A[I] := TRUE;
56: FOR I :=2 TO 16 DO
57: B[I] := TRUE;
58: FOR I :=-7T0 7 DO
59: C[I] := TRUE;

60: Trycol(1l);
6l: WRITELN;
62: END. (* Eightqueens *)
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Part I

Using the Debugger: Command Interface

This part contains complete information about the VMS debugger’s command
interface.

For information about the debugger’s DECwindows interface, see Part I.






2

Introduction to the Debugger: Command
Interface

This chapter introduces the VMS Debugger’s command interface. For information
about the debugger’s DECwindows interface, see Chapter 1.

The following information is provided in this chapter:
¢ An overview of the debugger’s features (Section 2.1)
* Enough information to get you started (Section 2.2)
e A sample debugging session (Section 2.3)
¢ A list of the debugger commands, by function (Section 2.4)
After you have read this chapter, consult the rest of this manual for additional
details about the command interface.
2.1 Overview of the Debugger

The debugger is a tool that helps you locate run-time programming or logic
errors, also known as bugs. You use the debugger with a program that has
been compiled and linked successfully but does not run correctly. For example,
the program might give incorrect output, go into an infinite loop, or terminate
prematurely.

You locate errors with the debugger by observing and manipulating your program
interactively as it executes. By entering debugger commands at the terminal, you
can do the following tasks:

¢ Control the program’s execution—start the program, stop at points of interest,
resume execution, and so on

¢ Trace the execution path of the program

*  Monitor changes in variables and other program entities

* Monitor exception conditions and language-specific events

¢ Examine and modify the values of variables, or force events to occur

* In some cases, test the effect of modifications without having to edit the
source code, recompile, and relink

These are the basic debugging techniques. After you are satisfied that you have
found the error in the program, you can edit the source code and compile, link,
and execute the corrected version.

As you use the debugger and its documentation, you will discover variations on
the basic techniques. You can also tailor the debugger for your own needs. The
next section summarizes the debugger features.
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2.1.1 Functional Features
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Programming Language Support

You can use the debugger with the following VAX languages: Ada, BASIC, BLISS,
C, COBOL, DIBOL, FORTRAN, MACRO-32, Pascal, PL/I, RPG II, and SCAN.
The debugger recognizes the syntax, data typing, operators, expressions, scoping
rules, and other constructs of a given language. If your program is written

in more than one language, you can change the debugging context from one
language to another during a debugging session with the SET LANGUAGE
command.

Symbolic Debugging

The VMS Debugger is a symbolic debugger. You can refer to program locations by
the symbols you used for them in your program—the names of variables, routines,
labels, and so on. You do not need to specify memory addresses or VAX registers
when referring to program locations, although you can, if you want.

Support for All Data Types

The debugger understands all compiler generated data types, such as integer,
floating point, enumeration, record, array, and so on. It displays the values of
program variables according to their declared type.

Flexible Data Format

The debugger permits a variety of data forms and types for entry and display. By
default, the source language of the program determines the format used for the
entry and display of data. You can also impose other formats. For example, by
using a type or radix qualifier with the EXAMINE command, you can display the
contents of a program location in ASCII, word-integer, or floating-point format.

Starting or Resuming Program Execution

You start or resume program execution with the GO or STEP commands. The
GO command causes the program to execute until a breakpoint is reached, a
watchpoint is modified, an exception is signaled, or the program terminates. The
STEP command enables you to execute a specified number of lines or instructions,
or up to the next instruction of a specified class.

Breakpoints

By setting breakpoints with the SET BREAK command, you can suspend program
execution at specified locations and check the current status of your program.
Rather than specify a location, you can also suspend execution on certain classes
of instructions or on every source line. Also you can suspend execution on certain

kinds of events, such as exceptions and tasking (multithread) events.

Tracepoints

By setting tracepoints with the SET TRACE command, you can monitor the
path of program execution through specified locations. When a tracepoint
is triggered, the debugger reports that the tracepoint was reached and then
continues execution. As with the SET BREAK command, you can also trace
through classes of instructions and monitor events.

Watchpoints

By setting a watchpoint with the SET WATCH command, you can cause execution
to stop whenever a particular variable or other memory location has been
modified. When a watchpoint is triggered, the debugger suspends execution

at that point and reports the old and new values of the variable.
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Manipulation of Variables and Program Locations

With the EXAMINE command, you can determine the value of a variable or
program location. The DEPOSIT command enables you to change that value. You
can then continue execution to see the effect of the change, without having to
recompile, relink, and rerun the program.

Evaluation of Expressions ,

With the EVALUATE command, you can compute the value of a source-language
expression or an address expression. You specify expressions and operators in the
syntax of the language to which the debugger is currently set.

Control Structures
You can use logical control structures (FOR, IF, REPEAT, WHILE) in commands
to control the execution of other commands.

Shareable Image Debugging

You can debug shareable images (images that are not directly executable).
The SET IMAGE command enables you to reference the symbols declared in
a shareable image.

Multiprocess Debugging

You can debug multiprocess programs (programs that run in more than one VMS
process). The SHOW PROCESS and SET PROCESS commands enable you to
display process information and control the execution of images in individual
processes.

Task Debugging

You can debug tasking programs (also known as multithread programs). These
programs use DECthreads or POSIX 1003.4a services, or use language-specific
tasking services (for example, Ada tasking programs). The SHOW TASK and SET
TASK commands enable you to display task information and control the execution
of individual tasks.

Vector Debugging

You can debug vectorized programs (programs that use VAX vector instructions).
You can control and monitor execution at the vector instruction level, examine
and deposit vector instructions, manipulate the contents of vector registers, use a
mask to display specific vector elements, and control synchronization between the
scalar and vector processors.

Terminal and Workstation Support
The debugger supports all VI-series terminals and MicroVAX workstations.

2.1.2 Convenience Features
Online Help
Online help is always available during a debugging session. Online help contains
information about all debugger commands and selected topics.
Source Code Display

You can display lines of source code for all supported languages during a
debugging session.
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Screen Mode

In screen mode, you can display and capture various kinds of information

in scrollable windows that can be moved around the screen and resized.
Automatically updated source, instruction, and register displays are available.
You can selectively direct debugger input, output, and diagnostic messages to
displays. You can also create "DO" displays that capture the output of specific
command sequences.

Keypad Mode

When you invoke the debugger, several commonly used debugger command
sequences are assigned by default to the keys of the numeric keypad (if you have
a VT52, VT100, or LK201 keyboard). Thus, you can enter these commands with
fewer keystrokes than if you were to type them at the keyboard. You can also
create your own key definitions.

Source Editing

As you find errors during a debugging session, you can use the EDIT command
to invoke any editor available on your system. You specify the editor you wish
with the SET EDITOR command. If you use the VAX Language-Sensitive Editor,
the editing cursor is automatically positioned within the source file whose code
appears in the screen-mode source display.

Command Procedures

You can direct the debugger to execute a command procedure (a file of debugger
commands) to re-create a debugging session, to continue a previous session, or
to avoid typing the same debugger commands many times during a debugging
session. You can pass parameters to command procedures.

Initialization Files

You can create an initialization file containing commands to set your default
debugging modes, screen display definitions, keypad key definitions, symbol
definitions, and so on. When you invoke the debugger, those commands are
executed automatically to tailor your debugging environment.

Log Files

You can record in a log file the commands you enter during a debugging session
and the debugger’s responses to those commands. You can use log files to keep
track of your debugging efforts, or you can use them as command procedures in
subsequent debugging sessions.

Symbol Definitions
You can define your own symbols to represent lengthy commands, address

-expressions, or values in abbreviated form.

2.2 Getting Started with the Debugger
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The way you use the debugger depends on several factors: the kind of program
you are working on, the kinds of errors you are looking for, and your own personal
style and experience with the debugger. This section explains the following basic
functions that apply to most situations.

¢ Compiling and linking your program to prepare for debugging
¢ Establishing the debugging configuration
¢ Invoking the debugger

¢ Ending a debugging session
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¢ Interrupting program execution and aborting debugger commands
¢ Entering debugger commands and getting online help
* Viewing your source code with the TYPE command and in screen mode

* Controlling program execution with the GO, STEP, and SET BREAK
commands, and monitoring execution with the SHOW CALLS, SET TRACE,
and SET WATCH commands

¢ Examining and manipulating data with the EXAMINE, DEPOSIT, and
EVALUATE commands

* Controlling symbol references with path names and the SET MODULE and
SET SCOPE commands

Several examples are language specific. However, the general concepts are
readily adaptable to all supported languages.

The sample debugging session in Section 2.3 illustrates how to use some of this
information to locate an error and correct it.

2.2,1 Compiling and Linking a Program to Prepare for Debugging
Before you can use the debugger, you must compile and link the modules
(compilation units) of your program as explained in this section. The following
example shows how to compile and link a FORTRAN program, consisting of a
single compilation unit named FORMS, before using the debugger.

Note

The /DEBUG and /NOOPTIMIZE qualifiers are compiler command
defaults for some languages. These qualifiers are used in the example for
emphasis.

$ FORTRAN/DEBUG/NOOPTIMIZE FORMS
$ LINK/DEBUG FORMS

The /DEBUG qualifier on the compiler command (FORTRAN in this case) directs
the compiler to write the symbol information associated with FORMS into the
object module, FORMS.OBJ, in addition to the code and data for the program.
This symbol information enables you to use the names of variables and other
symbols declared in FORMS with debugger commands. If your program has
several compilation units, you must compile each unit whose symbols you want to
reference with the /DEBUG qualifier.

Some compilers optimize the object code to reduce the size of the program or

to make it run faster. In such cases you should compile your program with the
/NOOPTIMIZE command qualifier (or equivalent) when preparing for debugging.
Otherwise, the contents of some program locations might be inconsistent with
what you would expect from viewing the source code. (After the program has
been debugged, you will probably want to recompile it without the /NOOPTIMIZE
qualifier to take advantage of optimization.)

The /DEBUG qualifier on the LINK command directs the linker to include all
symbol information that is contained in FORMS.OBJ in the executable image.
The qualifier also causes the VMS image activator to start the debugger at run
time. If your program has several object modules, you need to specify those
modules in the LINK command, for most languages.
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2.2.2 Establishing the Debugging Configuration

Before invoking the debugger as explained in Section 2.2.3, check that the
debugging configuration is appropriate for the kind of program you are going to
debug.

You can invoke the debugger in either the default configuration or the
multiprocess configuration to debug programs that run in either one or several
processes, respectively. The configuration depends on the current definition of
the logical name DBG$PROCESS. Thus, before invoking the debugger, enter the
DCL command SHOW LOGICAL DBG$PROCESS to determine the definition of
DBG$PROCESS.

Most of this chapter covers programs that run in only one process. For such
programs, DBG$PROCESS either should be undefined, as in the following
example, or should have the value DEFAULT:

$ SHOW LOGICAL DBGSPROCESS
$SHOW-S-NOTRAN, no translation for logical name DBGSPROCESS

If DBG$PROCESS has the value MULTIPROCESS, and you want to debug a
program that runs in only one process, enter the following command:

$ DEFINE DBGS$PROCESS DEFAULT

For more information about multiprocess debugging, see Chapter 10.

2.2.3 Invoking the Debugger

After you compile and link your program and establish the appropriate debugging
configuration, you can then invoke the debugger. To do so, enter the DCL
command RUN, specifying the executable image of your program as the
parameter. The following example shows how the debugger identifies itself

after you invoke it:

$ RUN FORMS
VAX DEBUG Version 5.5

%DEBUG-I-INITIAL, language is FORTRAN, module set to FORMS
DBG>

The diagnostic message that is displayed at debugger startup indicates that this
debugging session is initialized for a FORTRAN program and that the name of
the main program unit (the module containing the image transfer address) is
FORMS. The initialization sets up language-dependent debugger parameters.

At this point, execution is suspended at the beginning of the main program.
The DBG> prompt, which is displayed whenever the debugger suspends
execution, indicates that you can now enter debugger commands, as explained in
Section 2.2.6.

2.2.4 Ending a Debugging Session
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To end a debugging session and return to DCL level, type EXIT or press Ctrl/Z:

DBG> EXIT
$

The following message, displayed during a debugging session, indicates that your
program has completed normally:

%DEBUG-I-EXITSTATUS, is ’%SYSTEM-S-NORMAL, normal successful completion’
DBG>
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If you want to continue debugging after seeing this message, type EXIT and start
a new debugging session with the DCL RUN command. You could also restart
execution from within the debugging session with a command such as GO %LINE
1. However, this can produce unexpected results if, for example, some variables
have different values from when you first ran the program.

2.2.5 Interrupting Program Execution and Aborting Debugger Commands

If your program goes into an infinite loop during a debugging session so that
the debugger prompt does not reappear, press Ctrl/C. This interrupts program
execution and returns you to the debugger prompt (pressing Ctrl/C does not end
the debugging session). For example:

DBG> GO

DBG>

You can also press Ctrl/C to abort the execution of a debugger command. This is
useful if a command takes a long time to complete.

Pressing Ctrl/C when the program is not running or when the debugger is not
performing an operation has no effect.

If your program already has a Ctrl/C AST service routine enabled, use the
SET ABORT_KEY command to assign the debugger’s abort function to another
Ctrl-key sequence.

Pressing Ctrl/Y from within a debugging session has the same effect as pressing
Ctrl/Y during the execution of a program. Control is returned to the DCL
command interpreter ($ prompt).

2.2.6 Entering Debugger Commands

You can enter debugger commands any time you see the debugger prompt
(DBG>). To enter a command, type it at the keyboard and press RETURN. See
Section 1 of the command dictionary for complete rules on entering debugger
commands.

To obtain online help about debugger commands and specific subjects, proceed as
follows:

* To list the help topics, enter the HELP command.

* For an explanation of the help system, enter the command HELP HELP.
For example:

¢ To display help about the STEP command, enter the command HELP STEP.

¢ To display help about debugger diagnostic messages, enter the command
HELP MESSAGES.

Section 2 of the command dictionary explains the general format and severity
levels of debugger diagnostic messages. To obtain online help about a debugger
message, use the following general command format:

HELP MESSAGES message-identifier
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For example, to display information about the message whose identifier is
NOSYMBOL, enter the following command:

DBG> HELP MESSAGES NOSYMBOL

When you invoke the debugger, a few commonly used command sequences are
automatically assigned to the keys on the numeric keypad (to the right of the
main keyboard). Thus, you can perform certain functions either by typing a
command or by pressing a keypad key.

The predefined key functions are identified in Figure 2-1.

Most keypad keys have three predefined functions—DEFAULT, GOLD, and
BLUE.

* To enter a key’s DEFAULT function, press the key.

¢ To enter its GOLD function, first press and release the PF1 (GOLD) key, and
then press the key.

* To enter its BLUE function, first press and release the PF4 (BLUE) key, and
then press the key.

In Figure 2-1, the DEFAULT, GOLD, and BLUE functions are listed within each
key’s outline, from top to bottom, respectively. For example:

¢ Pressing keypad key KPO enters the STEP command.
* Pressing the PF1 key and then KPO enters the STEP/INTO command.
¢ Pressing the PF4 key and then KPO enters the STEP/OVER command.

Normally, keys KP2, KP4, KP6, and KP8 scroll screen displays down, left,
right, or up, respectively. By putting the keypad in the MOVE, EXPAND,

or CONTRACT state, indicated in Figure 2-1, you can also use these keys to
move, expand, or contract displays in four directions. Enter the HELP KEYPAD
command to display the keypad key definitions.

You can redefine keypad key functions with the DEFINE/KEY command.

2.2.7 Displaying Source Code

The debugger provides two modes for displaying information: noscreen mode and
screen mode. By default, when you invoke the debugger, you are in noscreen
mode, but you might find that it is easier to view source code in screen mode. The
following sections briefly describe both modes.

2.2.7.1 Noscreen Mode
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Noscreen mode is the default, line-oriented mode of displaying input and output.
The interactive examples throughout this chapter, excluding Section 2.2.7.2,
illustrate noscreen mode.

In noscreen mode, use the TYPE command to display one or more source lines.
For example, the following command displays line 7 of the module in which
execution is currently suspended:

DBG> TYPE 7
module SWAP_ROUTINES

IR TEMP := A;
DBG>
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Figure 2-1 Keypad Key Functions Predefined by the Debugger—Command Interface
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The display of source lines is independent of program execution. To display source
code from a module other than the one in which execution is currently suspended,
use the TYPE command with a path name to specify the module. For example,
the following command displays lines 16 to 21 of module TEST:

DBG> TYPE TEST\16:21

Path names are discussed in more detail in Section 2.2.8.1, in conjunction with
the STEP command.

You can also use the EXAMINE/SOURCE command to display the source line for
a routine or any other program location that is associated with an instruction.

Note that the debugger also displays source lines automatically when it suspends
execution at a breakpoint or watchpoint or after a STEP command, or when a
tracepoint is triggered (see Section 2.2.8).

After displaying source lines at various locations in your program, you can
redisplay the location at which execution is currently suspended by pressing
keypad key KP5.

If the debugger cannot locate source lines for display, it issues a diagnostic
message. Source lines might not be available for a variety of reasons. For
example:

¢ Execution is suspended within a module that was compiled or linked without
the /DEBUG qualifier.

¢ Execution is suspended within a system or shareable image routine for which
no source code is available.

¢ The source file was moved to a different directory after it was compiled (the
location of source files is embedded in the object modules). In this case, use
the SET SOURCE command to specify the new location.

* The module might need to be "set” with the SET MODULE command.
Module setting is explained in Section 2.2.10.1.

To invoke noscreen mode from screen mode, press the keypad key sequence
GOLD-PFS3 (or type SET MODE NOSCREEN). Note that you can use the TYPE
and EXAMINE/SOURCE commands in screen mode as well as noscreen mode.

2.2.7.2 Screen Mode
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Screen mode provides the easiest way to view your source code. To invoke screen
mode, press the PF3 key (or type SET MODE SCREEN). In screen mode, by
default the debugger splits the screen into three displays named SRC, OUT, and
PROMPT, as illustrated in Figure 2-2.
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Figure 2-2 Default Screen Mode Display Configuration
—S8RC: module SWAP ROUTINES~— scroll-source
2: with Text IO; use TEXT IO;
3: package body SWAP ROUTINES is
4: procedure SWAPT (A,B: in out INTEGER) is
5: TEMP: INTEGER;
6: begin
7 TEMP := A;
=> 8: A := B;
9: B := TEMP;
10: end;
11:
12: procedure SWAP2 (A,B: in out COLCR) is
= OUT-output

stepped to SWAP_ROUTINES\SWAP1\%LINE 8
SWAP_ROUTINES\SWAP1\A: 35

= PROMPT— error-program-prompt
DBG> STEP

DBG> EXAMINE A
DBG>

ZK-6502-GE

The SRC display shows the source code of the module in which execution is
currently suspended. An arrow in the left column points to the source line
corresponding to the current value of the program counter (PC). The PC is a VAX
register that contains the memory address of the instruction to be executed next.
The line numbers, which are assigned by the compiler, match those in a listing
file. As you execute the program, the arrow moves down and the source code is
scrolled vertically to center the arrow in the display.

The OUT display captures the debugger’s output in response to the commands
that you enter. The PROMPT display shows the debugger prompt, your input (the
commands that you enter), debugger diagnostic messages, and program output.

Both SRC and OUT are scrollable so you can see whatever information might
scroll beyond the display window’s edge. Use keypad key KP3 to select the
display to be scrolled (by default, SRC is scrolled). Use keypad key KP8 to
scroll up and keypad key KP2 to scroll down. Scrolling a display does not affect
program execution.

In screen mode, if the debugger cannot locate source lines for the routine in
which execution is currently suspended, it tries to display source lines in the
next routine down on the call stack for which source lines are available. If the
debugger can display source lines for such a routine, it issues the following
message:

$DEBUG-I-SOURCESCOPE, Source lines not available for .0\%PC.
Displaying source in a caller of the current routine.
DBG>

In such cases, the arrow in the SRC display identifies the line that contains code
following the call statement in the calling routine.
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2.2.8 Controlling and Monitoring Program Execution

This section explains how to perform the following tasks:

* Start and resume program execution

* Execute the program to the next source line, instruction, or other step unit
¢ Determine where execution is currently suspended

* Use breakpoints to suspend program execution at points of interest

¢ Use tracepoints to trace the execution path of your program through specified
locations

* Use watchpoints to monitor changes in the values of variables

With this information you can pick program locations where you can then test
and manipulat